Poasters Computer Forums

Computer Discussion => Hardware Discussion => Topic started by: Chandler on Apr 02, 2009, 06:10 AM

Title: Realtek ALC888 in Vista - Surprisingly Useable
Post by: Chandler on Apr 02, 2009, 06:10 AM
My first experience of onboard sound was with the Intel D815EEA board that my friend bought back in 2000 or 2001.  It was terrible. Moving the mouse produced a high pitched noise from the speakers. Hard disk access produced rumbling from the speakers.  Absolutely unusable, and he installed a SoundBlaster Live card.

When I bought my first nForce2-based board I decided to try onboard sound again. This was the ALC650 and that was a terrible codec; extremely noisy, bass heavy and easily distorted.

Every motherboard since has been the same let down, mostly Realtek AC97 junk. When I bought my Dell Dimension E521 it had a Sigmatel HD Audio chip, which actually sounded quite good.  There was a bit of background noise due to the motherboard design but the overall sound quality was fairly decent. When I installed Vista on it, there were also a lot of nice features that even my SoundBlaster card didn't have. Nonetheless, the background noise was too noticeable when using a hi-fi amplifier for speakers.

My latest board, an MSI K9AG Neo2-Digital, once again has Realtek on it, but this time it's the ALC888 which is a HD Audio codec.  On XP it was just as useless as every other Realtek chip had been. Poor drivers, poor control panel, poor features. With Vista though, it is great. The sound is clear and it supports all the those cool features in Vista's audio too. Something that has always annoyed me is that if you're using stereo speakers you're unable to add a subwoofer. Not in Vista though - just set it up as 5.1 and then turn off the missing surround speakers (where it will virtualise them) and allows the subwoofer to be used. The bass management is also rather good.  You can set the crossover frequency for the subwoofer but if you don't have a subwoofer there is a bass boost feature and low frequency protection. I presume that it shifts lower frequencies to above the cut-off you specify rather than just raising the gain EQ-style.

I was crtical of Microsoft for removing hardware DirectSound support in Vista, but they've done such a good job of making the audio subsystem useable for music and video that I forgive them. Creative have been able to add support for DirectSound hardware anyway.
Title: Re: Realtek ALC888 in Vista - Surprisingly Useable
Post by: pat on Apr 02, 2009, 01:46 PM
My Asus M2N uses the Soundmax ADI1988B 8-channel Codec and I find it very usable. Sound is clear and overall I find it all I really need. Works well with the TV as well with the Nvidia pass-through over HDMI.
Title: Re: Realtek ALC888 in Vista - Surprisingly Useable
Post by: scuzzy on Apr 02, 2009, 04:09 PM
My Gigabyte GA-EP45-UD3R mobo is using the ALC889A HD audio codec on WinXP. It has worked flawlessly well and I am quite happy with it. The same can be said with my Win7 setup, which is using all the same hardware.
Title: Re: Realtek ALC888 in Vista - Surprisingly Useable
Post by: Chandler on Apr 24, 2009, 03:21 PM
I think it's dying. Since installing Vista I've been using the standard Microsoft HD Audio driver. Occasionally I notice issues such as popping of the speakers, or noise when adjusting the volume and every few days anything audio-related would freeze (including the Windows volume control). Most of the issues began to occur in the evenings after the system had been on all day.

Today I decided to install the Realtek HD Audio driver and for a while it seemed to go fine, but again I'm experiencing issues this evening. This time, I'm receiving popup messages that it has detected that I've plugged in speakers to the Line Out jack. This is fine except for the fact that they've been connected the whole time.
Title: Re: Realtek ALC888 in Vista - Surprisingly Useable
Post by: Hoot on Sep 01, 2009, 03:54 AM
Yeah I have used onnboard (usually realtek) for quite some time too, but recently bought a creative Xfi. Lets just say in analog there's no comparison as the Xfi is about 35% better sounding. For free though realtek/soundmax solutions are great!
Title: Re: Realtek ALC888 in Vista - Surprisingly Useable
Post by: Chandler on Sep 03, 2009, 01:38 PM
The issue with the speaker connection popups turned out to be a conflict with Everest's system monitors. The popping noises were the speakers themselves. The weird buzzing noise when adjusting volume still happens from time to time.

I'm still using the Realtek drivers, because they give a lot of options for configuring the speakers compared to the stock Microsoft driver. I've manually reverted to the standard Microsoft SysFX APOs though - Realtek install their own, none of which are as good as the ones built into Vista. The biggest one is that the standard Microsoft bass management lets you set cross-over frequency, the Realtek one doesn't.

Overall, I'm quite impressed with the MSI K9AG Neo2-Digital. I don't think it matches my Dell system with a Creative X-Fi (and the reason for that was that the onboard audio is quite noisy on that system) but it's good enough.